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4. The User Interface – Commands 

Users can increase their productivity significantly by customizing the interface. Some of the 

ways to do this include: 

• Commands that are used frequently can be placed on the Ribbon, Quick Access 

toolbar, or Right Mouse Button (Shortcut) menus.  

• Commands that are rarely or never used can be moved to the overflow menus. 

• The icons that appear on the In Graphics Toolbar can also be controlled. 

4.1. Creo Parametric Operating Modes 

Let’s get the bad news out of the way at the beginning. In Creo Parametric 3.0, customizations 

to the User Interface are mode-dependent. In other words, if you customize the interface in 

part mode, when you open an assembly, you will not see the customizations that you made.  

When defining a customization, you may want to “bite the bullet” and apply the customizations 

to all the modes that you use up front, especially the popular ones, such as: 

• No model open 

• Part (standard) 

• Sheetmetal 

• Assembly 

• Drawing 

These issues are resolved in Creo Parametric 4.0, when customizations can be propagated to 

all modes. 

4.2. Quick Access Toolbar 

The Quick Access toolbar appears by default in the upper left corner of the screen. Initially it 

appears in part and assembly modes as: 
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The available commands from left to right are: 

• Window adjustments (Restore, Move, Size, Lower, Minimize, Maximize, Close) 

• New 

• Open 

• Save 

• Undo and Redo 

• Regenerate  

• Windows (select a window to activate) 

• Close  

• Customize Quick Access Toolbar 

The commands that you use most frequently should be added here. For example, some of the 

commands I like to appear here include: 

• Erase Not Displayed 

• Model Properties 

• Server Management (for creating and changing Workspaces when using Windchill). 

To customize the Quick Access toolbar, perform the following steps: 

1. Click either of the following: 

a. File > Options > Quick Access Toolbar. 

b. In the Quick Access toolbar, click the Customize Quick Access Toolbar  icon > 

More Commands. 
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2. Use the Choose commands from: drop-down list to select which menu or tab (e.g., 

Model, Analysis, Annotate, Tools, etc.) from which you want to select commands. 

Hint: All Commands might be easiest since it does not require you to know the 

tab on which a command resides. 

3. Select the command that you want to appear in the Quick Access Toolbar and click the 

Add button. 

4. Repeat steps 2 and 3 for all commands you wish to appear in the Quick Access Toolbar. 

5. If there are any commands that appear in the toolbar that you wish to remove, select 

them from the Customize Quick Access Toolbar list and select Remove. 

6. As desired, select commands from the “Customize Quick Access Toolbar” list and use 

the up and down arrows to change the order. 

7. If desired, check the box for Show Quick Access Toolbar below the Ribbon. 
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8. (Optional) Click Import/Export > Export all Ribbon and Quick Access Toolbar 

customizations. In the Export dialog box, navigate to either the Home or Startup 

directory. 

9. Click OK. 

As mentioned in section 3.1, this process will have to be repeatedly for all desired operating 

modes in Creo Parametric 3.0. 

4.2.1. Separators 

Separators are vertical bars that can be added to the Quick Access Toolbar. To add them, 

follow the same general process as described in section 4.2. At the top of each group of 

commands, you will see a line that says <Separator>: 

 

Click on this and use the Add button just as you would for a Creo Parametric command. Here 

is an example of a Separator added between the Close and Component Interface icons: 

 

4.3. The Ribbon 

As mentioned at the beginning of this chapter, enormous gains in productivity can be realized 

by customizing aspects of the interface. This is especially true of the Ribbon. Users will be more 

efficient if they can find the commands they use most often quicker, and they will be distracted 

less by removing commands that are seldom or never used. 

The Ribbon can be customized in order to: 

• Add commands to custom tabs or custom groups within existing tabs. 
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• Turn off entire groups or tabs. 

• Add or remove commands from the Overflow menus (the down arrows that provide 

access to the less frequently used commands). 

 

Example of an Overflow menu. 

• Add custom tabs. 

Let’s look at some scenarios in which we might want to do this. Here is the default Ribbon in 

Part mode: 

 

Let’s say that you don’t have a license for ISDX; in that case, there’s no need for you to have the 

Style tool on the Ribbon. Therefore, you may want to move it to the Overflow menu out of your 

way. Similarly, there are a number of commands from the Model Intent Overflow menu – 

Relations, Parameters, Family Table, and so on – that you may want on the Model tab instead 

of accessing from the Tools tab or the Overflow. If you’re using Windchill, you may want a tab 

for data management related commands – accessing the Server Manager, checking in, 

checking out – as well as custom Mapkeys for checking the quality of your CAD data. 

There are numerous ways in which to initiate customization of the Ribbon, including: 

• Right clicking on an icon in the ribbon and choosing Move to Overflow. 

• Right clicking on a command in an Overflow menu and selecting Move to Group. 
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• Right clicking on the Ribbon or Quick Access Toolbar and selecting Customize the 

Ribbon. 

• Clicking File > Options > Customize Ribbon. 

The first two choices will make immediate changes on-the-fly to your interface. The latter two 

choices open the Options dialog box: 

 

The operations you can perform from here include: 

• Check or uncheck boxes for tabs or commands groups to control their display. 

• Create new command groups on existing tabs. 

• Create new custom tabs. 

• Adding and removing commands to new custom tabs and new command groups on 

existing tabs. 

• Change the order of commands on all tabs via the up and down keys or drag and drop. 
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• Moving existing commands from the main Ribbon to the Overflows and vice versa. 

• Changing the size of icons. 

Let’s discuss some of these functions in more detail. 

To select which commands to move to the Ribbon, pick them from the “Choose commands 

from:” column. When a model is open, it will show the commands available from the Model tab. 

Use the drop-down list to change the tab from which you wish to select commands: 

 

Some tips: 

• All Commands might be the easiest choice. 

• Application Menu contains commands from the File tab. 

• The Mapkeys group enables you to convert Mapkeys into Ribbon icons. This will be 

covered in Chapter 7. 

When you click the New Tab button, a new tab is inserted at the active location under the 

“Customize the Ribbon” column. You can also right click on an object in that column and 

choose Add New Tab. It is named New Tab (Custom) and has one group created underneath it 

named New Group (Custom). 

To create a new group, click the New Group button or right click and select New Group. The 

group will be inserted underneath the active location in the “Customize the Ribbon” column. 

To rename new or existing tabs or groups, you can right click on the object and select Rename, 

or select it and click the Rename button. Renaming a tab will also rename any associated 

Overflow menus. 
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Cascades are groupings of commands available from a drop-down arrow. (The Measure 

command from the Analysis tab is very similar to a cascade.) To create a cascade, select a 

group and click the New Cascade button. You can also right click on a group or a command 

within a group and select Add New Cascade.  

To create a new Overflow menu, right click on a group and select Add New Overflow. 

As mentioned, much of the customization can be done from right mouse button menus. For 

example: 

 

 

4.3.1. Modifying the Icon Display 

The display size of icons can be controlled. For example, let’s say you use the Copy Geometry 

command a lot, so you want it to stand out from the other commands in the Get Data group. 

You can change it to be displayed as a large button: 
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To change the icon display, click File > Options > Customize Ribbon. Then select a command 

underneath the Customize the Ribbon column and click the Modify button. This will open a 

menu with radio buttons for: 

• Default Style 

• Small Button 

• Small Button – No Icon 

• Large Button 

In addition, there is a check box that allows you to Hide Command Label so that the icon 

appears without any accompanying text. This check box can also be utilized by right clicking on 

an icon in the Ribbon directly. 

4.3.2. Restoring Defaults 

Sometimes after customizing the Ribbon, you want to restore it to its original configuration. To 

do so, you can click the button for Restore Defaults. This will provide the following choices: 

• Restore only selected Ribbon tab. 

• Restore all Ribbon tabs and Quick Access Toolbar customizations. 

4.3.3. Importing and Exporting Customizations 

The Import/Export button provides you with the following options: 

• Export all Ribbon tabs and Quick Access Toolbar customizations: to save a 

creo_parametric_customization.ui file to a specified location. 

• Import customization file: to read in a creo_parametric_customization.ui file. 

Depending on how your system has been customized previously, you may have some 

additional export options: 

• Export admin and user customizations. 

• Export only user customizations. 

• Export only run directory customizations. 

4.3.4. Toggling the Ribbon Display 

Some people don’t like how much “real estate” the Ribbon takes up at the top of the screen. It 

can be minimized, so that only the tab names appear. When a tab is clicked, the Ribbon will be 
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expanded. To minimize the Ribbon, right click on it and select Minimize the Ribbon. Repeat this 

process later to expand it again. 

Holding down the CTRL and F1 keys will also toggle the Ribbon from being minimized or 

expanded. 

 

4.4. Right Mouse Button (Shortcut) Menus 

The Shortcut menu, sometimes referred to as the “asynchronous menu” in PTC literature, is 

the menu that pops up when you hold down the right mouse button. What appears in the 

menu depends on: 

• What operating mode you are in. 

• Whether you have something selected. 

• What kind of object is selected.  

You will likely find that the shortcut menus contain commands that you rarely use. By removing 

those, you can improve your workflows. 

You can perform the following customizations of the Shortcut Menus: 

• Turn commands on or off. 

• Change the order of groups or commands in a group using arrows or drag and drop. 

• Choose whether certain commands appear as a “mini toolbar” or as “regular” 

commands. For example, the Edit commands can be configured to display as follows: 
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Display of Edit commands as Mini Toolbar versus Regular. 

Note: In Creo 4.0, Mini Toolbar refers to the new menu of command icons that 

opens when geometry is selected in the new selection paradigm:

 

Since the right mouse button menus are context sensitive, the choices for selected item 

include: 

• No Selection. 

• Top Level Part or Top-Level Assembly, depending on what model you have open. 

• Component (assembly mode only). 

• Features. 

• Geometry. 

• Datums. 

• Quilt. 

• Annotation. 

• Surface Region. 

• Mechanism Objects (assembly mode only). 

The Shortcut Menus themselves are organized into the following groups: 

• Selection Options. These are related to selection involving operations related to Flexible 

Modeling, 3D Annotations, and so forth, but not Preselection Options such as Pick From 

List (which can’t – and shouldn’t – be disabled). 

• Primary. This includes commands such as Activate, Open, Suppress, Resume, and the 

Edit Actions (e.g., Edit Dimensions, Edit Definition, Edit References). 

• Secondary. This includes commands like Copy and the Paste Options. 

• Creation. This includes commands like Insert Mode and Pattern. 

• Transfer Commands: for sending models via email. 
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• Object Settings (e.g., Group, Hide, Representation). 

• Object Commands. This includes a wide variety of commands, including Delete, Delete 

Pattern, Replace, Move to/from footer, and commands related to editing 3D 

Annotations. 

• Properties (e.g., Parameters, Rename, Information). 

• Additional Actions. For example, View Changes, Locate in Model Tree, and Mathcad-

related commands. 

• Windchill. This includes CAD data management commands such as Check Out, Check 

In, and Update. 

To customize the right mouse button menus, perform the following steps: 

1. Open a model. 

2. Click File > Options > Shortcut Menu. 
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3. From the “Choose selected item” list on the left, click on the appropriate selection-

based right mouse button menu. 

4. From the “Customize the Shortcut Menu” list on the right, expand the appropriate 

command group. 

5. Check boxes on or off depending on which commands you want to appear. 

6. Use drag and drop or the arrows to change the order of the groups or the commands 

within the groups. 

7. As desired, right click on cascades (arrows indicating commands that appear as mini 

toolbars) and select Show as regular commands or Show as a mini toolbar. 

8. Repeat steps 3 through 7 as desired. 

9. Click OK. 

Be aware that customizing the Shortcut Menus are dependent on what object you have open 

when you execute the command. The menus for assemblies are different than parts, and you 

do not have to ability to configure the menus for sketches. 

4.4.1. Restoring Defaults 

Just like customizing the Ribbon, when you customize the Shortcut menus, you have the 

Restore Defaults button. When you click it, you have the following choices: 

• Restore selected menu only. 

• Restore all menus. 

4.4.2. Importing and Exporting Shortcut Menu Customizations 

Also similar to customizing the Ribbon, customizing the Shortcut menus has an Import/Export 

button. Clicking it provides you with the following options: 

• Export shortcut menu customization. 

• Import customization file. 

Depending on how your system has been customized previously, you may have some 

additional export options: 

• Export admin and user customizations. 

• Export only user customizations. 

• Export only run directory customizations. 
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4.5. In Graphics Toolbar 

The In Graphics Toolbar appears by default at the top of the Graphics Area: 

 

The icons that appear in it by default are, from left to right: 

• Zoom All 

• Zoom In 

• Zoom Out 

• Repaint 

• Display Style (Shading with Reflections, Shading with Edges, Shading, No Hidden, 

Hidden Line, and Wireframe) 

• Saved Orientations 

• View Manager 

• Datum Display (Show All, Axis, Point, Coordinate System, Plane) 

• Show Annotations 

• Show Spin Center 

You can customize both its location and the icons that appear inside it. The expedient method 

is to right click on the In Graphics Toolbar itself in the Graphics Area, which will open the 

following menu: 
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The check boxes allow you to turn the display of various icons on and off. 

The Location fly-out menu allows you to choose between the following radio buttons for the 

Location of the In Graphics Toolbar: 

• Show on the Top 

• Show on the Right 

• Show on the Bottom 

• Show on the Left 

• Show in the Status Bar 

• Do Not Show 

If displayed in the Status Bar, it appears at the bottom right of the Creo Parametric interface as 

follows: 

 

The Size fly-out menu allows you to choose whether the icons appear small (default), medium, 

or large. 

As the command states, Reset to Default removes all customizations and restores initial 

settings. 
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4.5.1. In Graphics Toolbar Location 

The position of the In Graphics Toolbar can also be controlled from the Options dialog box. To 

change the location, perform the following steps: 

1. Click File > Options > Window Settings. 

 

2. Click the drop-down list under Graphics Toolbar settings for Main Window – Graphics 

Toolbar location and choose whether to display it on the top, bottom, right, left, not at 

all, or in the Status Bar.  

3. If desired, repeat step 2 for Accessory Window – Graphics Toolbar location. 

4. Click OK. 
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4.6. Window Settings 

The Window Settings dialog box, accessible from File > Options > Window Settings, contains a 

variety of controls: 

 

Many of these are discussed in other parts of this book. The dialog box is broken up into the 

following groups: 

• Navigation tabs settings: see section Error! Reference source not found.. 

• Model Tree settings: see section Error! Reference source not found.. 

• Browser settings: see section Error! Reference source not found.. 

• Accessory window settings. 

• Graphics toolbar settings: see section 4.5.1. 

• General settings. 
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The Accessory Window is displayed during: 

• Component placement. 

• Creation of Copy Geometry, Publish Geometry, Merge / Inheritance, and Shrinkwrap 

features. 

• Placement of Sheetmetal Form features. 

Under Accessory window settings, the window size can be changed to either Default or 

Maximized. 

General Settings contains two controls: 

• Resume Display of Dialog Boxes. Some dialog boxes present an option that reads ‘In 

the future, do not display this message.’ This button enables the display of those dialog 

boxes again. 

• Reset Panels’ Position. The tabs on dashboards – such as Placement, References, 

Options, Properties, and so on – can actually be disconnected from the dashboard and 

dragged into the Graphics Area. This option reattaches the dashboard tabs to their 

default location. 
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Thanks for reading. If you would like to read more of “Configuring Creo Parametric 3.0,” you can 

find us on Amazon.com. If you like what you read, please write a review. If you didn’t like it or 

disagree, please feel free to reach out to me. 

 

Dave Martin 

dmartin@creowindchill.com 

 

Follow us on social media at: 

https://www.facebook.com/CreoWindchill/ 

https://twitter.com/CreoWindchill  

https://www.linkedin.com/company/creo-windchill/  

 

 


