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3. The User Interface – Graphics  

3.1. UI Customization File 

When you customize the Creo Parametric User Interface (UI), the changes are automatically 

stored in the creo_parametric_customization.ui file. There are a few intricacies that determine 

where the files are stored and how they are utilized, including: 

• The presence of an Administrator UI customization file. 

• Windchill. 

• Configuration Options. 

3.1.1. Administrator UI Customization File 

Just like administrators can set configuration options for you, they can also set UI 

customizations. To create an administrator UI customization file, perform the following steps: 

1. Customize the interface. This results in an automatically created 

creo_parametric_customization.ui file. 

2. Rename this file to creo_parametric_admin_customization.ui. 

3. Store the file in the text folder in the Creo Parametric loadpoint. 

This behaves very much like the config.pro file stored in the same location. It is read in first but 

gets overridden by the settings in the user’s UI customization file. 

3.1.2. The User’s UI Customization File 

When the user customizes the interface, another UI customization file is created. If he or she is 

not connected to Windchill, that file is automatically stored in the following folder: 

<user>\AppData\Roaming\PTC\ProENGINEER\Wildfire\.wf\.Settings 

This location can be found by opening Windows Explorer and typing %Appdata% into the 

address bar and hitting the ENTER key: 
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Once in the Roaming folder, if you navigate to the folder specified above, you will see the UI 

customization file: 

 

If the user is connected to Windchill, the file will be saved to the PTC_WF_ROOT\.Settings folder. 

3.1.3. Configuration Option 

There is a configuration option that overrides the behavior specified in section 3.1.2. If 

load_ui_customization_run_dir is set to yes, then Creo Parametric will save User Interface 

changes to and load them from the Run directory instead. 

For more information about the Run directory, see section 2.2.2 on Changing the Startup 

Directory. 

3.2. Config.win File  

Prior to the release of Creo Parametric 1.0, UI customizations were stored in a file called 

config.win. As of Creo Parametric 3.0, any customizations made to modes involving a the 

ribbon interface are stored in the creo_parametric_customization.ui file. In the unlikely event 

that you are using Report mode or Markup mode, if you customize the interface, those 

changes will be stored in config.win. 
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3.3. Working in Full Screen 

In Creo Parametric 4.0, certain commands still trigger the Menu Manager (more so in Drawing 

Mode than Part or Assembly). Because of that, Creo Parametric still does not open full screen 

by default. 

   

Examples of Menu Managers in Creo Parametric 4.0. 

Setting the configuration option open_window_maximized to yes starts and keeps you in full 

screen. 

3.4. Presentation Mode 

Presentation Mode was added in Creo Parametric 4.0. When you are in Presentation Mode, 

the interface increases to use the full screen, and the following parts of the interface are 

hidden: 

• The Ribbon. 

• The Navigator. 

• The Message Area. 

You will see the Graphics Area, the In Graphics Toolbar, and the tabs for Combination States if 

you have them enabled: 
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To enter and exit Presentation Mode, use the F11 key. You can also enter and exit using the 

icon on the right from the toolbar in the lower left corner of the interface: 

 

When you enter Presentation Mode, the following warning will open in the lower left corner of 

the interface: 

 

While you are in Presentation Mode, moving your mouse over the top, left, or bottom sides of 

the screen will bring up the Ribbon, Navigator, and Message Area, respectively. While hovering 

over the bottom of the screen, right clicking on the Message Area will open a menu with the 

option to Pin Status Bar while in Presentation Mode: 
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3.5. System Appearance 

Creo Parametric 4.0 introduced Themes to control the skin of the interface. The Default Theme 

has changed to a light grey background instead of the default white in Creo Parametric 3.0 to 

reduce eye strain. The Theme controls both the Interface and System Colors. 

The Themes available out of the box are: 

• Default Theme 

• Light Theme (Creo Parametric 3.0 default) 

• Dark Theme 

• Custom Theme 

The choices for Interface are: 

• Default 

• Light 

• Dark 

The choices for System Colors are: 

• Default 

• Light (Previous Creo Default) 

• Dark 

• Black on White 

• White on Black 

• Custom 
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The Theme, Interface, and System Colors can be changed by clicking File > Options > System 

Appearance. 

Some people prefer the System Colors that were available in Pro/ENGINEER Wildifire and 

earlier versions. Those can be downloaded from the PTC Knowledge Base here. Note that 

accessing this page requires a PTC.com account enabled with user support. The Import button 

to the right of System Colors can be used to load a System Colors File. 

Regardless of which Theme the user starts with, the colors used can be customized further. 

 

The colors are organized into three main categories: 

• Global Colors 

• ECAD Conductor Colors 

• Simulation Entity Colors 

The Global Colors are broken down into the following subcategories: 

• Graphics, for things like: 
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o Background color, letter color, and datum tags. 

o Geometry (solid wireframe), hidden line edges, shaded edges, and quilts. 

o Preselection, selection, and highlighting. 

• Datums, including datum plane sides and datum tags. 

• Geometry, including the edge colors for one-sided and two-sided edges. 

• Sketcher, for things like: 

o Entities and endpoints. 

o References, dimensions, and constraints. 

o Analysis and diagnostics. 

• Simple Search. 

After customizing the colors, click the Export button to save the syscol.scl file to a different 

location. Then set the configuration option system_colors_file to the folder and filename. 

Note: the following configuration options for colors were removed in Creo Parametric 4.0: 

• system_background_color 

• system_curves_color 

• system_geometry_color 

• system_hidden_color  

• system_highlight_color 

• system_letter_color  

• system_section_color  

• system_sheetmetal_color 

3.5.1. Lower Left Corner Text 

When you apply certain actions to the model, text will display in the lower left corner of the 

Graphics Area. For example: 

 

Some of the actions that will display this information includes: 

• Entering Insert Mode 

• Applying View Manager actions: 

o Simplified Representations o Cross Sections 
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o Explode States 

o Style States 

o Layer States 

o Appearance States 
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Sometimes you do not want this text to appear, such as when you are presenting in Creo 

Parametric during a design review or creating images of your model. Unfortunately, there is no 

direct way to turn off this information from displaying in the Graphics Area. As an alternative, 

you can change the color of the text to match the background color. This text is controlled by 

the Secondary highlight color. 

To change this, perform the following steps: 

1. Click File > Options > System Appearance. 

2. Expand Graphics. 

3. Click on Secondary highlight and change the color to the same color as Background. 

 

4. Click OK. 

If you perform this often, you may want to consider creating a Mapkey to automate these 

steps. 

3.6. Model Display 

Model Display settings control: 

• The type of projection. 

• Display of entities when spinning the model. 

• Shading. 
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• Rendering. 

To access these controls, click File > Options > Model Display: 

 

Almost all the settings have a corresponding configuration option. Some of the ones you may 

find more useful, along with their configuration option in parentheses, include: 

• Default Model Orientation (orientation): the axonometric projection of the model on 

the computer screen can be Isometric, Trimetric, or User Defined. 

• Model display settings when reorienting the model: 

o Show the orientation center (spin_with_orientation_center). 

o Show datums (spin_with_part_entities). 

o Show silhouette edges (spin_with_silhouettes). 

o Show animation. To turn this off, set the option max_animation_time to 0. 

• Shaded model display settings: 

o Shade quality level (shade_quality), from 1 to 50. 

o Show surface features (shade_surface_feat). 

o Show datum curve features (shade_with). 
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o Shade very small surfaces (skip_small_surfaces). 

o Show textures on shaded model (texture). 

o Enable transparency (transparency). 

3.7. Entity Display 

Entity Display allows us to control things like: 

• Default display for models: Wireframe, Hidden Line, No Hidden Line, Shading, Shading 

with Edges, and Shading with Reflections. 

• Edge Display Quality: low, medium, high, or very high. 

• Display of datum features and their associated tags. 

• Display of dimension tolerances.  

• Display of Annotations and Annotation Elements. 

• Display of cables and pipes as centerlines or thick entities. 

To change the settings for these entities, click File > Options > Entity Display. 
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Some of the more significant settings (with their corresponding configuration option in 

parentheses) include: 

• Geometry Display Settings: 

o Default display for models (display): Wireframe, Hidden Line, No Hidden Line, 

Shading, Shading with Edges, and Shading with Reflections. 

o Edge display quality (edge_display_quality): low, medium, high, and very high. 

o Tangent edge display (tangent_edge_display): solid, no display, phantom, 

centerline, or dimmed. 

o Anti-aliasing (enable_fsaa) to reduce the jagged look of edges displayed at an 

angle. 

o Colors assigned to model surfaces (color). 

o Silhouette edges (display_silhouette_edges). 

• Datum Display: 

o Individual settings to control the display of datum planes, axes, points, 

coordinate systems, and their associated tags. 
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o How datum points appear (datum_point_symbol): cross, dot, circle, triangle, or 

square. 

o Images (display_images): pictures imported into the model and placed on datum 

planes or planar surfaces. 

• Dimensions, Annotations, Notes, and Reference Designators: 

o Tolerance display (tol_display). 

o Reference designators (ref_des_display). 

o Annotations (display_annotations). 

• Assembly Display Settings : 

o Explode state animation (animate_explode_states) and duration 

(explode_animation_max_time). 

o Display of interference in cross sections (show_interference_in_sections). 

• Routed Systems: 

o Cables displayed with their specified diameter or as curves along the center 

(display_thick_cables). 

o Same control for pipes (display_thick_pipes). 

3.8. Appearances 

Colors can be applied to models and model entities (like surfaces) using the View > 

Appearances command. Creo Parametric comes with a limited number of pre-defined 

appearances, but you can create your own. An appearance can consist of: 

• Color, as defined by RGB (red green blue) and/or HSV (hue saturation value). 

• Highlight color. 

• Properties such as intensity, ambience, shine, highlight, reflection, and transparency. 

• Textures, bump maps, or decals. 

On the GrabcCAD website, Klemen Eržen has made a full Pantone colors appearance file 

available for download for free. You can find it at the following URL:  

https://grabcad.com/library/pantonecolorsfull-dmt 

To create or modify the appearances available to your model or session, start by clicking View 

> Appearances > Appearance Manager. 
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In the Appearances Manager dialog box, you can perform actions including: 

• Create new appearances by using the  icon under My Appearances. 

• Use File > Append to add colors from another .dmt or older .map file. 

• Use File > Save As to store an appearance.dmt file. Note: You must save the file with the 

name appearance.dmt; otherwise, Creo Parametric won’t read it. 

Then set the configuration option pro_colormap_path to the name of the folder that contains 

the appearance.dmt file. 

3.9. Textures 

As mentioned in the previous section, appearances can include textures. Creo Parametric 

comes with a set of pre-defined textures located at: 

<loadpoint>\graphic-library\textures 
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Additional directories can be appended to the location that Creo Parametric searches for 

textures using the texture_search_path configuration option. However, to avoid errors, you may 

want to set the configuration option save_texture_with_model to yes. 

3.10. Tip: How to Change the Spin Center’s Location 

When the Spin Center is visible in the Graphics Area, the model rotates about that object when 

you hold down the middle mouse button and rotate the mouse. Sometimes you want the 

model to spin about a different location on the model. In large assemblies, it becomes 

convenient to spin the model about a point or vertex closer to where you are working. 

To change the Spin Center’s location, perform the following steps. 

1. Click on the Saved Orientations  icon in the In Graphics Toolbar and select the 

Reorient command. 

 

2. In the View dialog box, click on the Type drop-down list (which says Orient by reference) 

and select Preferences. 
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3. Then select the radio button for Point or vertex, and select a new location. 
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4. A Menu Manager opens that allows you to select a location on a curve, edge, or surface 

instead of a point or vertex. 

 

5. Alternatively, you can use the radio buttons for Edge or axis or Coordinate System if 

you prefer.  

6. Click OK when finished and your Spin Center will be relocated. 

Unfortunately, you cannot save the new Spin Center with the model. 
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Thanks for reading. If you would like to read more of “Configuring Creo Parametric 4.0,” you can 

find us on Amazon.com. If you like what you read, please write a review. If you didn’t like it or 

disagree, please feel free to reach out to me. 

 

Dave Martin 

dmartin@creowindchill.com 

 

Follow us on social media at: 

https://www.facebook.com/CreoWindchill/ 

https://twitter.com/CreoWindchill  

https://www.linkedin.com/company/creo-windchill/  

 

 


